6

10 months agoby Shailesh Jakhaniya

Packer package install error

Hello Sir,

I have to install your laravel packer package into my system but get some error like as below.

Problem 1 - Conclusion: don't install bitfumes/laravel-packer v1.5.4 - bitfumes/laravel-packer v1.5.0 requires laravel-zero/framework 5.7. -> satisfiable by laravel-zero/frameworkv5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.12, v5.7.13, v5.7.14, v5.7.15, v5.7.16, v5.7.17, v5.7.18, v5.7.19, v5.7.2, v5.7.20, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7, v5.7.8, v5.7.9. - bitfumes/laravel-packer v1.5.1 requires laravel-zero/framework 5.7. -> satisfiable by laravel-zero/frameworkv5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.12, v5.7.13, v5.7.14, v5.7.15, v5.7.16, v5.7.17, v5.7.18, v5.7.19, v5.7.2, v5.7.20, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7, v5.7.8, v5.7.9. - bitfumes/laravel-packer v1.5.2 requires laravel-zero/framework 5.7. -> satisfiable by laravel-zero/frameworkv5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.12, v5.7.13, v5.7.14, v5.7.15, v5.7.16, v5.7.17, v5.7.18, v5.7.19, v5.7.2, v5.7.20, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7, v5.7.8, v5.7.9. - laravel-zero/framework v5.7.0 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.1 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.10 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.11 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.12 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.13 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.14 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.15 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.16 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.17 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.18 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.19 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.2 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.20 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.3 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.4 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.5 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.6 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.7 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.8 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - laravel-zero/framework v5.7.9 requires nunomaduro/laravel-console-menu ^2.0 -> satisfiable by nunomaduro/laravel-console-menuv2.0.0, v2.0.1, v2.1.0. - nunomaduro/laravel-console-menu v2.0.0 requires php-school/cli-menu ^3.0 -> satisfiable by php-school/cli-menu3.0.0, 3.1.0. - nunomaduro/laravel-console-menu v2.0.1 requires php-school/cli-menu ^3.0 -> satisfiable by php-school/cli-menu3.0.0, 3.1.0. - nunomaduro/laravel-console-menu v2.1.0 requires php-school/cli-menu ^3.0 -> satisfiable by php-school/cli-menu3.0.0, 3.1.0. - php-school/cli-menu 3.1.0 requires ext-posix -> the requested PHP extension posix is missing from your system. - php-school/cli-menu 3.0.0 requires ext-posix -> the requested PHP extension posix is missing from your system. - Installation request for bitfumes/laravel-packer ^1.5 -> satisfiable by bitfumes/laravel-packerv1.5.0, v1.5.1, v1.5.2, v1.5.3, v1.5.4. - bitfumes/laravel-packer v1.5.3 requires laravel-zero/framework 5.8. -> satisfiable by laravel-zero/frameworkv5.8.0, v5.8.1, v5.8.2, v5.8.3, v5.8.4, v5.8.5. - laravel-zero/framework v5.8.0 requires psr/log ^1.1 -> satisfiable by psr/log1.1.0. - laravel-zero/framework v5.8.1 requires psr/log ^1.1 -> satisfiable by psr/log1.1.0. - laravel-zero/framework v5.8.2 requires psr/log ^1.1 -> satisfiable by psr/log1.1.0. - laravel-zero/framework v5.8.3 requires psr/log ^1.1 -> satisfiable by psr/log1.1.0. - laravel-zero/framework v5.8.4 requires psr/log ^1.1 -> satisfiable by psr/log1.1.0. - laravel-zero/framework v5.8.5 requires psr/log ^1.1 -> satisfiable by psr/log1.1.0. - Conclusion: don't install psr/log 1.1.0

To enable extensions, verify that they are enabled in your .ini files: - E:\xampp\php\php.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

Installation failed, reverting ./composer.json to its original content.

79

Sarthak Shrivastava replied 9 months ago

2

Just update your composer globally. run composer global update

and after this it will install properly.

Ask Question
Most Visited
Categories